Skip to main content
← All vulnerabilities
CVE-2026-120185

ken678 YznCMS Auth Group Group.php Backend privileges management

Published
Last modified
published
Not listed in CISA KEV
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub

Summary

YznCMS, a PHP content management system by ken678, contains a flaw in its admin authentication group handling that lets a remote attacker manipulate user group permissions. This improper privilege management could allow an attacker to gain access to backend functions beyond what their account should permit.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

A security flaw has been discovered in ken678 YznCMS up to 2.2.0. The affected element is the function Backend of the file app/admin/controller/auth/Group.php of the component Auth Group Handler. Performing a manipulation results in improper privilege management. The attack can be initiated remotely. Upgrading to version 2.2.1 is sufficient to fix this issue. The patch is named ed16cd7f7f73e0316ffa8a148d. You should upgrade the affected component.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • ken678 YznCMS

    2.0, 2.1, 2.2.0

References 7

VulDB

gitee.com