Skip to main content
← All vulnerabilities
CVE-2026-119571

Parse Server 9.7.0 before 9.10.5-alpha.10 Installation Update Misdirection via Installation ID

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.10.5-alpha.10
None on Exploit-DB, Metasploit or GitHub

Summary

Parse Server, an open-source backend framework, is affected from version 9.7.0 up to a fixed release. An attacker who knows another installation's object ID can cause updates to be applied to a different installation, potentially bypassing protected-field handling in beforeSave triggers when that exemption setting is enabled.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

Parse Server from 9.7.0 before 9.10.5-alpha.10 contains an authorization flaw that applies _Installation updates addressed by object ID to the installation named in the X-Parse-Installation-Id header. When protectedFieldsTriggerExempt is enabled, attackers knowing another installation's object ID can make a beforeSave trigger process that installation's protected fields while writing elsewhere.

Timeline

  1. CVE published
  2. First seen by cve.now

Affected versions

  • parse-community parse-server

    From 9.7.0 · fixed in 9.10.5-alpha.10

References 2

GitHub · parse-community/parse-server

vulncheck.com