Skip to main content
← All vulnerabilities
CVE-2026-118687EUVD-2026-112392GHSA-J9WC-WG7R-6RM3GHSA-24VH-Q7RG-243W

Coder before 2.29.21, 2.34.12, 2.35.9, 2.36.7, and 2.37.4 Missing Audience Validation in GCP Instance-Identity Authentication

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.37.4, 2.36.7, 2.35.9, 2.34.12, 2.29.21
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Coder before 2.29.21, 2.30.0 before 2.34.12, 2.35.0 before 2.35.9, 2.36.0 before 2.36.7, and 2.37.0 before 2.37.4 does not validate the audience claim of GCE instance-identity JWTs at the POST /api/v2/workspaceagents/google-instance-identity endpoint. Attackers who obtain an unexpired format=full identity token minted for another relying party can replay it to obtain that workspace agent's session token, which remains valid until the workspace's next build.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • coder coder

    From 2.37.0 · fixed in 2.37.4

  • coder coder

    From 2.36.0 · fixed in 2.36.7

  • coder coder

    From 2.35.0 · fixed in 2.35.9

  • coder coder

    From 2.30.0 · fixed in 2.34.12

  • coder coder

    fixed in 2.29.21

References 2

GitHub · coder/coder

vulncheck.com