n8n before 1.123.85, 2.43.5, and 2.44.1 Credential Permission Check Bypass
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.123.85, 2.44.1, 2.43.5
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
n8n, a workflow automation platform, is affected by this vulnerability. An authenticated member user could exploit it to use credentials they lack permission to access, potentially causing sensitive credential values to be sent to destinations chosen by the attacker.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability that allows member users to use credentials they cannot access by omitting default node parameters. Attackers can save and run workflows where pre-execution checks skip credential slots, causing decrypted credential values to be sent to attacker-chosen destinations.
Timeline
- CVE published
- First seen by cve.now
Affected versions
- n8n-io n8n
fixed in 1.123.85
- n8n-io n8n
From 2.44.0 · fixed in 2.44.1
- n8n-io n8n
From 2.0.0 · fixed in 2.43.5