SemanticMediaWiki 3.0.0 before 7.3.1 Reflected XSS via Special:Ask Separator Parameters
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 7.3.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
SemanticMediaWiki, an extension for the MediaWiki wiki platform, is affected by a reflected cross-site scripting flaw in its Special:Ask query page. Attackers can use a crafted link to run malicious scripts in a victim's browser within the wiki, potentially stealing login sessions or security tokens.
Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.
Read the original description
SemanticMediaWiki from 3.0.0 before 7.3.1 contains a reflected cross-site scripting vulnerability in Special:Ask, which outputs separator parameters (sep, propsep, valuesep, delim, separator) without HTML escaping in list, category, DSV, and CSV result printers. Unauthenticated attackers can send victims crafted Special:Ask links using request_type=raw or request_type=special_page to execute JavaScript in the wiki's origin, stealing sessions or CSRF tokens.
Timeline
- CVE published
- Record last updated
- First seen by cve.now
Affected versions
- SemanticMediaWiki SemanticMediaWiki
From 3.0.0 · fixed in 7.3.1