Skip to main content
← All vulnerabilities
CVE-2026-116143EUVD-2026-109404GHSA-RW29-W85J-WC72GHSA-FP46-842C-2V83

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 Policy Bypass in PS, PDF and XPS Decoders

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 7.1.2-33, 6.9.13-58
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

ImageMagick, a widely used image processing library, is affected when its security policy for PostScript, PDF, and XPS files can be bypassed. An attacker can craft input that makes it process more pages or scenes than the policy allows, which could exhaust system resources.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

ImageMagick before 6.9.13-58 and 7.x before 7.1.2-33 contains a policy bypass in the PS, PDF and XPS decoders that allows the security policy's list length limit on scene selection to be circumvented. Attackers supplying a specific argument can cause ImageMagick to process more scenes than permitted, potentially exhausting resources.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  4. Record last updated

Affected versions

  • ImageMagick ImageMagick

    From 7.0.0-0 · fixed in 7.1.2-33

  • ImageMagick ImageMagick

    fixed in 6.9.13-58

References 2

GitHub · ImageMagick/ImageMagick

vulncheck.com