Skip to main content
← All vulnerabilities
CVE-2026-115915EUVD-2026-110035GHSA-H3RC-J82P-2C3HPYSEC-2026-4346

vLLM: Untrusted EPS inputs can trigger denial of service or Ghostscript RCE

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 0.32.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

vLLM, an open-source engine for serving large language models, is affected through its image-loading code, which can be tricked into processing malicious EPS image data. This can let an attacker crash the service or, on hosts with a vulnerable Ghostscript installation, run commands with the privileges of the vLLM process.

Summarized by anthropic/claude-haiku-5.5. Verify details against the original sources.

Read the original description

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

Timeline

  1. CVE published
  2. First seen by cve.now
  3. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  4. Record last updated

Affected versions

  • vllm-project vllm

    fixed in 0.32.0

  • vllmPyPI

    fixed in 0.32.0

  • vllmPyPI

    From 0.30.0 · fixed in 0.32.0

References 4

GitHub · vllm-project/vllm